// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z0-9_\-]+(,?[a-zA-Z0-9_\-]+))*$").unwrap();
let string = "These should match:
host_one,host_two,host_three
hostone
env_qa
env-qa,env-qa,env-qa
1as-asd,asd1,awdf_adfw,1dasd-asda_asd
Everything else should not match
,env_qa
env-qa,env-qa,env-qa,
$%5
,
,,
,
,
,
,
asdf,
$
$%5
,
,asdf
\"asdf, \"
asdf,
\" , \"
\";\"
1as-asd,,asd1,awdf_adfw,1dasd-asda_asd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}