use strict;
my $str = 'These should match:
host_one,host_two,host_three
hostone
env_qa
env-qa,env-qa,env-qa
1as-asd,asd1,awdf_adfw,1dasd-asda_asd
Everything else should not match
,env_qa
env-qa,env-qa,env-qa,
$%5
,
,,
,
,
,
,
asdf,
$
$%5
,
,asdf
"asdf, "
asdf,
" , "
";"
1as-asd,,asd1,awdf_adfw,1dasd-asda_asd';
my $regex = qr/^([a-zA-Z0-9_\-]+(,?[a-zA-Z0-9_\-]+))*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}