import re
regex = re.compile(r"^([a-zA-Z0-9_\-]+(,?[a-zA-Z0-9_\-]+))*$", flags=re.MULTILINE)
test_str = ("These should match:\n"
"host_one,host_two,host_three\n"
"hostone\n"
"env_qa\n"
"env-qa,env-qa,env-qa\n"
"1as-asd,asd1,awdf_adfw,1dasd-asda_asd\n\n"
"Everything else should not match\n"
",env_qa\n"
"env-qa,env-qa,env-qa,\n"
"$%5\n"
",\n"
",,\n"
" ,\n"
" , \n"
" , \n"
", \n"
"asdf,\n"
"$\n"
"$%5\n"
",\n"
",asdf\n"
"\"asdf, \"\n"
"asdf,\n"
"\" , \"\n"
"\";\"\n"
"1as-asd,,asd1,awdf_adfw,1dasd-asda_asd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")