#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".+(?=\\)"
Local $sString = "C:\Users\KlausP\Pictures\Screenpresso\201.8-01-24_13h40_38.png" & @CRLF & _
"\\Users\KlausP\Pictures\Sc.test.reenpresso\201.8-01-24_13h40_38.png" & @CRLF & _
"\\Users\KlausP\P.net\ictures\Sc.test.reen\presso\201.8-01-24_13h40_38.png" & @CRLF & _
".\hallo" & @CRLF & _
".\.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")