re = /.+(?=\\)/
str = 'C:\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png
\\\\Users\\KlausP\\Pictures\\Sc.test.reenpresso\\201.8-01-24_13h40_38.png
\\\\Users\\KlausP\\P.net\\ictures\\Sc.test.reen\\presso\\201.8-01-24_13h40_38.png
.\\hallo
.\\.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end