$re = '/.+(?=\\\\)/';
$str = 'C:\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png
\\\\Users\\KlausP\\Pictures\\Sc.test.reenpresso\\201.8-01-24_13h40_38.png
\\\\Users\\KlausP\\P.net\\ictures\\Sc.test.reen\\presso\\201.8-01-24_13h40_38.png
.\\hallo
.\\.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);