using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+(?=\\)";
string input = @"C:\Users\KlausP\Pictures\Screenpresso\201.8-01-24_13h40_38.png
\\Users\KlausP\Pictures\Sc.test.reenpresso\201.8-01-24_13h40_38.png
\\Users\KlausP\P.net\ictures\Sc.test.reen\presso\201.8-01-24_13h40_38.png
.\hallo
.\.txt";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}