import Foundation
let pattern = #".+(?=\\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
C:\Users\KlausP\Pictures\Screenpresso\201.8-01-24_13h40_38.png
\\Users\KlausP\Pictures\Sc.test.reenpresso\201.8-01-24_13h40_38.png
\\Users\KlausP\P.net\ictures\Sc.test.reen\presso\201.8-01-24_13h40_38.png
.\hallo
.\.txt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)