const regex = new RegExp('.+(?=\\\\)', 'g')
const str = `C:\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png
\\\\Users\\KlausP\\Pictures\\Sc.test.reenpresso\\201.8-01-24_13h40_38.png
\\\\Users\\KlausP\\P.net\\ictures\\Sc.test.reen\\presso\\201.8-01-24_13h40_38.png
.\\hallo
.\\.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}