import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+(?=\\\\)";
final String string = "C:\\Users\\KlausP\\Pictures\\Screenpresso\\201.8-01-24_13h40_38.png\n"
+ "\\\\Users\\KlausP\\Pictures\\Sc.test.reenpresso\\201.8-01-24_13h40_38.png\n"
+ "\\\\Users\\KlausP\\P.net\\ictures\\Sc.test.reen\\presso\\201.8-01-24_13h40_38.png\n"
+ ".\\hallo\n"
+ ".\\.txt";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}