using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'time': (?P<Time>\w+\s\w+\s\d+\s\d+:\d+:\d{2}), 'type': (?P<Type>[a-zA-Z]+_\w+:\w+)";
string input = @"{'time': Mon Jan 20 11:34:13, 'type': access_compat:error}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}