package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'time': (?P<Time>\w+\s\w+\s\d+\s\d+:\d+:\d{2}), 'type': (?P<Type>[a-zA-Z]+_\w+:\w+)`)
var str = `{'time': Mon Jan 20 11:34:13, 'type': access_compat:error}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}