use strict;
my $str = '{\'time\': Mon Jan 20 11:34:13, \'type\': access_compat:error}';
my $regex = qr/'time': (?P<Time>\w+\s\w+\s\d+\s\d+:\d+:\d{2}), 'type': (?P<Type>[a-zA-Z]+_\w+:\w+)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}