re = /'time': (?P<Time>\w+\s\w+\s\d+\s\d+:\d+:\d{2}), 'type': (?P<Type>[a-zA-Z]+_\w+:\w+)/
str = '{\'time\': Mon Jan 20 11:34:13, \'type\': access_compat:error}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end