package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[^A-Z0-9]*|[A-Z0-9]*)([A-Z0-9][^A-Z]+|$)`)
var str = `colorPrettylightsSyntaxComment
colorPrettylightsSyntaxConstant
colorPrettylightsSyntaxEntity
colorPrettylightsSyntaxStorageModifierImport
colorPrettylightsSyntaxEntityTag
colorPrettylightsSyntaxKeyword
colorPrettylightsSyntaxString`
var substitution = "$1-$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}