$re = '`(^[^A-Z0-9]*|[A-Z0-9]*)([A-Z0-9][^A-Z]+|$)`m';
$str = 'colorPrettylightsSyntaxComment
colorPrettylightsSyntaxConstant
colorPrettylightsSyntaxEntity
colorPrettylightsSyntaxStorageModifierImport
colorPrettylightsSyntaxEntityTag
colorPrettylightsSyntaxKeyword
colorPrettylightsSyntaxString';
$subst = "$1-$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;