import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[^A-Z0-9]*|[A-Z0-9]*)([A-Z0-9][^A-Z]+|$)";
final String string = "colorPrettylightsSyntaxComment\n"
+ "colorPrettylightsSyntaxConstant\n"
+ "colorPrettylightsSyntaxEntity\n"
+ "colorPrettylightsSyntaxStorageModifierImport\n"
+ "colorPrettylightsSyntaxEntityTag\n"
+ "colorPrettylightsSyntaxKeyword\n"
+ "colorPrettylightsSyntaxString";
final String subst = "$1-$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}