re = /(^[^A-Z0-9]*|[A-Z0-9]*)([A-Z0-9][^A-Z]+|$)/m
str = 'colorPrettylightsSyntaxComment
colorPrettylightsSyntaxConstant
colorPrettylightsSyntaxEntity
colorPrettylightsSyntaxStorageModifierImport
colorPrettylightsSyntaxEntityTag
colorPrettylightsSyntaxKeyword
colorPrettylightsSyntaxString'
subst = '$1-$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result