// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[^A-Z0-9]*|[A-Z0-9]*)([A-Z0-9][^A-Z]+|$)").unwrap();
let string = "colorPrettylightsSyntaxComment
colorPrettylightsSyntaxConstant
colorPrettylightsSyntaxEntity
colorPrettylightsSyntaxStorageModifierImport
colorPrettylightsSyntaxEntityTag
colorPrettylightsSyntaxKeyword
colorPrettylightsSyntaxString";
let substitution = "$1-$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}