import re
regex = re.compile(r"(^[^A-Z0-9]*|[A-Z0-9]*)([A-Z0-9][^A-Z]+|$)", flags=re.MULTILINE)
test_str = ("colorPrettylightsSyntaxComment\n"
"colorPrettylightsSyntaxConstant\n"
"colorPrettylightsSyntaxEntity\n"
"colorPrettylightsSyntaxStorageModifierImport\n"
"colorPrettylightsSyntaxEntityTag\n"
"colorPrettylightsSyntaxKeyword\n"
"colorPrettylightsSyntaxString")
subst = "$1-$2"
result = regex.sub(subst, test_str)
if result:
print(result)