import Foundation
let pattern = #"(^[^A-Z0-9]*|[A-Z0-9]*)([A-Z0-9][^A-Z]+|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
colorPrettylightsSyntaxComment
colorPrettylightsSyntaxConstant
colorPrettylightsSyntaxEntity
colorPrettylightsSyntaxStorageModifierImport
colorPrettylightsSyntaxEntityTag
colorPrettylightsSyntaxKeyword
colorPrettylightsSyntaxString
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1-$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)