#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(slovo(?:.+?$){6})"
Local $sString = "dfsdfsfjd" & @CRLF & _
"gfgjkhdfjkg" & @CRLF & _
"fsdkjfhsdkj slovo skjfhjkshdfjk" & @CRLF & _
"sd;lkf;sdlf" & @CRLF & _
"sdkfjsdklfj" & @CRLF & _
"dlskfjskldfj" & @CRLF & _
"ldskfjlksdfj" & @CRLF & _
"lsdfjlkdsjfkl" & @CRLF & _
"lsdkjfklsdfj" & @CRLF & _
"kldjflkdsj" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")