$re = '/(slovo(?:.+?$){6})/ms';
$str = 'dfsdfsfjd
gfgjkhdfjkg
fsdkjfhsdkj slovo skjfhjkshdfjk
sd;lkf;sdlf
sdkfjsdklfj
dlskfjskldfj
ldskfjlksdfj
lsdfjlkdsjfkl
lsdkjfklsdfj
kldjflkdsj
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);