import Foundation
let pattern = #"(slovo(?:.+?$){6})"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
dfsdfsfjd
gfgjkhdfjkg
fsdkjfhsdkj slovo skjfhjkshdfjk
sd;lkf;sdlf
sdkfjsdklfj
dlskfjskldfj
ldskfjlksdfj
lsdfjlkdsjfkl
lsdkjfklsdfj
kldjflkdsj
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}