re = /(slovo(?:.+?$){6})/m
str = 'dfsdfsfjd
gfgjkhdfjkg
fsdkjfhsdkj slovo skjfhjkshdfjk
sd;lkf;sdlf
sdkfjsdklfj
dlskfjskldfj
ldskfjlksdfj
lsdfjlkdsjfkl
lsdkjfklsdfj
kldjflkdsj
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end