const regex = /(slovo(?:.+?$){6})/ms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(slovo(?:.+?$){6})', 'ms')
const str = `dfsdfsfjd
gfgjkhdfjkg
fsdkjfhsdkj slovo skjfhjkshdfjk
sd;lkf;sdlf
sdkfjsdklfj
dlskfjskldfj
ldskfjlksdfj
lsdfjlkdsjfkl
lsdkjfklsdfj
kldjflkdsj
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}