import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(slovo(?:.+?$){6})";
final String string = "dfsdfsfjd\n"
+ "gfgjkhdfjkg\n"
+ "fsdkjfhsdkj slovo skjfhjkshdfjk\n"
+ "sd;lkf;sdlf\n"
+ "sdkfjsdklfj\n"
+ "dlskfjskldfj\n"
+ "ldskfjlksdfj\n"
+ "lsdfjlkdsjfkl\n"
+ "lsdkjfklsdfj\n"
+ "kldjflkdsj\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}