#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)lgbt.*"
Local $sString = "homophobia" & @CRLF & _
"transphobia" & @CRLF & _
"hate speech" & @CRLF & _
"I suck at writting RegExes" & @CRLF & _
"lgbt-I-LOVE-HOMOPHOBIA-AND-I-AM-ALSO-ZOOPHILE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")