// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)lgbt.*").unwrap();
let string = "homophobia
transphobia
hate speech
I suck at writting RegExes
lgbt-I-LOVE-HOMOPHOBIA-AND-I-AM-ALSO-ZOOPHILE";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}