import Foundation
let pattern = #"lgbt.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
homophobia
transphobia
hate speech
I suck at writting RegExes
lgbt-I-LOVE-HOMOPHOBIA-AND-I-AM-ALSO-ZOOPHILE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}