import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "lgbt.*";
final String string = "homophobia\n"
+ "transphobia\n"
+ "hate speech\n"
+ "I suck at writting RegExes\n"
+ "lgbt-I-LOVE-HOMOPHOBIA-AND-I-AM-ALSO-ZOOPHILE";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}