package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)lgbt.*`)
var str = `homophobia
transphobia
hate speech
I suck at writting RegExes
lgbt-I-LOVE-HOMOPHOBIA-AND-I-AM-ALSO-ZOOPHILE`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}