re = /lgbt.*/i
str = 'homophobia
transphobia
hate speech
I suck at writting RegExes
lgbt-I-LOVE-HOMOPHOBIA-AND-I-AM-ALSO-ZOOPHILE'
# Print the match result
str.match(re) do |match|
puts match.to_s
end