$re = '/lgbt.*/i';
$str = 'homophobia
transphobia
hate speech
I suck at writting RegExes
lgbt-I-LOVE-HOMOPHOBIA-AND-I-AM-ALSO-ZOOPHILE';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);