#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<\s*meta\b.*\bproperty="(og:[^"]+)"\s.*\bcontent="([^"]*)"
Local $sString = "<meta property="og:title" content="111">" & @CRLF & _
"<meta data-one="true" property="og:description" content="222">" & @CRLF & _
"<meta data-two="true" property="og:image" content="333">" & @CRLF & _
"<meta data-three="true" data-another="true" property="og:url" content="444">" & @CRLF & _
"<meta data-four="true" data-another="true" notaproperty="og:url" content="444">" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")