const regex = new RegExp('<\\s*meta\\b.*\\bproperty="(og:[^"]+)"\\s.*\\bcontent="([^"]*)', 'g')
const str = `<meta property="og:title" content="111">
<meta data-one="true" property="og:description" content="222">
<meta data-two="true" property="og:image" content="333">
<meta data-three="true" data-another="true" property="og:url" content="444">
<meta data-four="true" data-another="true" notaproperty="og:url" content="444">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}