use strict;
my $str = '<meta property="og:title" content="111">
<meta data-one="true" property="og:description" content="222">
<meta data-two="true" property="og:image" content="333">
<meta data-three="true" data-another="true" property="og:url" content="444">
<meta data-four="true" data-another="true" notaproperty="og:url" content="444">
';
my $regex = qr~<\s*meta\b.*\bproperty="(og:[^"]+)"\s.*\bcontent="([^"]*)~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}