using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\s*meta\b.*\bproperty=""(og:[^""]+)""\s.*\bcontent=""([^""]*)";
string input = @"<meta property=""og:title"" content=""111"">
<meta data-one=""true"" property=""og:description"" content=""222"">
<meta data-two=""true"" property=""og:image"" content=""333"">
<meta data-three=""true"" data-another=""true"" property=""og:url"" content=""444"">
<meta data-four=""true"" data-another=""true"" notaproperty=""og:url"" content=""444"">
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}