package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\s*meta\b.*\bproperty="(og:[^"]+)"\s.*\bcontent="([^"]*)`)
var str = `<meta property="og:title" content="111">
<meta data-one="true" property="og:description" content="222">
<meta data-two="true" property="og:image" content="333">
<meta data-three="true" data-another="true" property="og:url" content="444">
<meta data-four="true" data-another="true" notaproperty="og:url" content="444">
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}