import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*meta\\b.*\\bproperty=\"(og:[^\"]+)\"\\s.*\\bcontent=\"([^\"]*)";
final String string = "<meta property=\"og:title\" content=\"111\">\n"
+ "<meta data-one=\"true\" property=\"og:description\" content=\"222\">\n"
+ "<meta data-two=\"true\" property=\"og:image\" content=\"333\">\n"
+ "<meta data-three=\"true\" data-another=\"true\" property=\"og:url\" content=\"444\">\n"
+ "<meta data-four=\"true\" data-another=\"true\" notaproperty=\"og:url\" content=\"444\">\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}