// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<\s*meta\b.*\bproperty="(og:[^"]+)"\s.*\bcontent="([^"]*)"#).unwrap();
let string = "<meta property=\"og:title\" content=\"111\">
<meta data-one=\"true\" property=\"og:description\" content=\"222\">
<meta data-two=\"true\" property=\"og:image\" content=\"333\">
<meta data-three=\"true\" data-another=\"true\" property=\"og:url\" content=\"444\">
<meta data-four=\"true\" data-another=\"true\" notaproperty=\"og:url\" content=\"444\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}