const regex = new RegExp('((\\w+|\\-)+)(\\W*):(?=(.+);)', '')
const str = `#LasVegas .billboard { text-decoration: blink; }
.ninja, #Snowden { visibility: hidden; }
.oliveoil
{
z-index: 1;
}
.water
{
z-index: 0;
}
#poop {
float : none ;
color : brown ;
width : 15cm ;
height : 120cm ;
}
.God { position: absolute; display: none; }
#blackhole { padding: -9999em; }
.word { font-family: "Comic Sans", "Times New Roman", sans-serif ; }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}