$re = '/((\w+|\-)+)(\W*):(?=(.+);)/';
$str = '#LasVegas .billboard { text-decoration: blink; }
.ninja, #Snowden { visibility: hidden; }
.oliveoil
{
z-index: 1;
}
.water
{
z-index: 0;
}
#poop {
float : none ;
color : brown ;
width : 15cm ;
height : 120cm ;
}
.God { position: absolute; display: none; }
#blackhole { padding: -9999em; }
.word { font-family: "Comic Sans", "Times New Roman", sans-serif ; }';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);