import re
regex = re.compile(r"((\w+|\-)+)(\W*):(?=(.+);)")
test_str = ("#LasVegas .billboard { text-decoration: blink; }\n\n"
".ninja, #Snowden { visibility: hidden; }\n\n\n"
".oliveoil\n"
"{\n"
" z-index: 1;\n"
"}\n"
".water\n"
"{\n"
" z-index: 0;\n"
"}\n\n"
"#poop {\n"
" float : none ;\n"
" color : brown ;\n\n"
" width : 15cm ;\n"
" height : 120cm ;\n"
"}\n\n"
".God { position: absolute; display: none; }\n"
"#blackhole { padding: -9999em; }\n\n"
".word { font-family: \"Comic Sans\", \"Times New Roman\", sans-serif ; }")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")