#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix)^" & @CRLF & _
"(?P<filename>.+\.cs)" & @CRLF & _
"\(" & @CRLF & _
"(?P<line>\d+)" & @CRLF & _
"," & @CRLF & _
"(?P<col>\d+)" & @CRLF & _
"\):\040" & @CRLF & _
"(?P<level>\w+)" & @CRLF & _
"\040" & @CRLF & _
"(?P<error>.+)"
Local $sString = "Template.cs(24,16): error CS0246: The type or namespace name `TemplateFrame' could not be found. Are you missing a using directive or an assembly reference?" & @CRLF & _
"Mob.cs(20,19): error CS1519: Unexpected symbol `void' in class, struct, or interface member declaration" & @CRLF & _
"Compilation failed: 1 error(s), 0 warnings" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")