use strict;
my $str = 'Template.cs(24,16): error CS0246: The type or namespace name `TemplateFrame\' could not be found. Are you missing a using directive or an assembly reference?
Mob.cs(20,19): error CS1519: Unexpected symbol `void\' in class, struct, or interface member declaration
Compilation failed: 1 error(s), 0 warnings
';
my $regex = qr/^
(?P<filename>.+\.cs)
\(
(?P<line>\d+)
,
(?P<col>\d+)
\):\040
(?P<level>\w+)
\040
(?P<error>.+)/ixp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}