// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ix)^
(?P<filename>.+\.cs)
\(
(?P<line>\d+)
,
(?P<col>\d+)
\):\040
(?P<level>\w+)
\040
(?P<error>.+)").unwrap();
let string = "Template.cs(24,16): error CS0246: The type or namespace name `TemplateFrame' could not be found. Are you missing a using directive or an assembly reference?
Mob.cs(20,19): error CS1519: Unexpected symbol `void' in class, struct, or interface member declaration
Compilation failed: 1 error(s), 0 warnings
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}