$re = '/^
(?P<filename>.+\.cs)
\(
(?P<line>\d+)
,
(?P<col>\d+)
\):\040
(?P<level>\w+)
\040
(?P<error>.+)/ix';
$str = 'Template.cs(24,16): error CS0246: The type or namespace name `TemplateFrame\' could not be found. Are you missing a using directive or an assembly reference?
Mob.cs(20,19): error CS1519: Unexpected symbol `void\' in class, struct, or interface member declaration
Compilation failed: 1 error(s), 0 warnings
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);