import re
regex = re.compile(r"""
^
(?P<filename>.+\.cs)
\(
(?P<line>\d+)
,
(?P<col>\d+)
\):\040
(?P<level>\w+)
\040
(?P<error>.+)
""", flags=re.IGNORECASE | re.VERBOSE)
test_str = ("Template.cs(24,16): error CS0246: The type or namespace name `TemplateFrame' could not be found. Are you missing a using directive or an assembly reference?\n"
"Mob.cs(20,19): error CS1519: Unexpected symbol `void' in class, struct, or interface member declaration\n"
"Compilation failed: 1 error(s), 0 warnings\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")