import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?P<filename>.+\\.cs)\n"
+ "\\(\n"
+ "(?P<line>\\d+)\n"
+ ",\n"
+ "(?P<col>\\d+)\n"
+ "\\):\\040\n"
+ "(?P<level>\\w+)\n"
+ "\\040\n"
+ "(?P<error>.+)";
final String string = "Template.cs(24,16): error CS0246: The type or namespace name `TemplateFrame' could not be found. Are you missing a using directive or an assembly reference?\n"
+ "Mob.cs(20,19): error CS1519: Unexpected symbol `void' in class, struct, or interface member declaration\n"
+ "Compilation failed: 1 error(s), 0 warnings\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}